Shop Mobile More Submit  Join Login
Win7 Calculator for XP, Vista by ShikharSrivastava Win7 Calculator for XP, Vista by ShikharSrivastava
Well, Well!! The wait is over.It's finally here,

First ever Windows 7 like working Calculator for xp and Vista.
It is a new species of calculator as compared to my previous calculators.
This one is a program coded by me in Visual Basic 2010 therefore your system needs to have Dot Net Framework 4 or above.
It is working perfectly in standard mode and scientific mode is partially functional.

FEATURES--------------------------------------------------------------------------------------------------------
-Standard mode working perfectly
-Scientific mode is partially functional
-Better and smoother fonts
-Date Calculations dialog box added(Though it doesn't resembles Windows 7's original one, but looks nice)
-Includes help file (Displayed when help is clicked in menustrip)
-Unit Conversions working perfectly
-Leightweight and portable.
-Coded by me in Visual Basic 2010.
-Requirements: XP or Vista with dot net framework 4 or above. Download link for .net framework 4 [link]
-A candy to eye.

INSTRUCTIONS----------------------------------------------------------------------------------------------------
Either run "Calc.exe" file directly from this ZIP and create its shortcut at Desktop and in Programs menu for future use,

OR

Replace original "calc.exe" file in "Windows\System32" folder with this new one.

Don't forget to backup your original calc.exe!!!
----------------------------------------------------------------------------------------------------------------

Don't edit it without my permission.
Any comments, suggestions, advices are welcomed.
----------------------------------------------------------------------------------------------------------------

If you liked my this project then please give me points at [link]
------------------------------------------------------------------------------------------------------------------------------------------------------
Download link for . net framework 4 [link]
Add a Comment:
 
:iconainq:
ainq Featured By Owner Jun 18, 2010
you just need a new aero theme
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner Jun 19, 2010  Professional General Artist
Oh. It's actually True transparency.
I don't use aero themes on my system.
Reply
:iconainq:
ainq Featured By Owner Jun 19, 2010
oh... :bow:
Reply
:iconrivenroth740:
RivenRoth740 Featured By Owner Jun 2, 2010  Student General Artist
please, make a translation to spanish and other languages.
good job@ calc.
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner Jun 2, 2010  Professional General Artist
Hey!Thanks.
But the problem is that I don't know Spanish.
The languages I know are English, Hindi and Sanskrit.
But if you know then you can translate it.
You can mail me if you want the source code.
Email ID : GoShikhar@gmail.com
Reply
:iconrivenroth740:
RivenRoth740 Featured By Owner Jun 2, 2010  Student General Artist
ok. give me the source code and i can translate it. u could study spanish. learn more languages.
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner Jun 3, 2010  Professional General Artist
I've mailed you regarding this.
Reply
:iconrivenroth740:
RivenRoth740 Featured By Owner Jun 3, 2010  Student General Artist
ok. i'll check my mail.
Reply
:icondncube:
dncube Featured By Owner May 29, 2010  Hobbyist General Artist
it requires : .net framework 4.0

u can port it to .net framework 2.0 as there is option for that in vs 2010
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner May 29, 2010  Professional General Artist
Hey I want some help.

Ist problem-
When I go to advance compile options, there in the drop down menu under "Target Framework" three options are available.
1. .Net Framework 4
2. .Net Framework 4 Client Profile
3. Install other frameworks...

It is not displaying .Net Framework 3.5. And it is strange to notice that my PC has dot net framework 3.5 already installed.

IInd problem-
When I tried to install .Net framework 2.0 after downloading it from Microsoft's website by clicking "Install other Frameworks..." an error message is displayed -
"Setup cannot continue because this version of the .net framework is incompatible with the previously installed one.For more information see microsoft's website."

Please help me get out of this I'm getting furious.I'm quite new to VB 10
Reply
:iconmagnumhearted:
MAGNUMHEARTED Featured By Owner Oct 26, 2010
hi there. sorry for interrupting but im quite familiar with this one
as i've work my program to run with lower .net requirements.

1. Try going to your project properties
2. Go to 'references' tab
3. Click on 'unused reference'
4. Remove all of them. (since they are unused)

note: there is a number indicating the version of .NET Fw required.

i'm sure some of those unused references uses .NET Fw 4.0 that made your software require .NET 4.0

from there try to apply the Target Framework settings. ;P

hope this helps. :thumbsup: but im not really sure if this will work for you.
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner Nov 7, 2010  Professional General Artist
Hey!Thanks for your suggestion on this.I'll try this out and will let you know. :-)
Reply
:iconmagnumhearted:
MAGNUMHEARTED Featured By Owner Nov 8, 2010
Welcome. :D
Reply
:icondncube:
dncube Featured By Owner May 30, 2010  Hobbyist General Artist
when u install .net framework from option Install other frameworks... it gets installed.

For me it works....
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner May 30, 2010  Professional General Artist
But not for me.
Reply
:icondncube:
dncube Featured By Owner May 30, 2010  Hobbyist General Artist
try to contact kishan bagaria he will help u out.

Coz i'm hving exams a week later
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner May 30, 2010  Professional General Artist
Okay. Thanks anyway.
Reply
:iconainq:
ainq Featured By Owner May 29, 2010
just like the real thing!
Reply
:iconhoppy01:
hoppy01 Featured By Owner May 29, 2010
Looks good. Thank you.

...but when I first tried to run it (on XP Pro SP3 with Net Framework 3.5 SP1), I got an error saying I needed .NF 4. The calculator ran after installing .NF4.
Reply
:iconkishan-bagaria:
Kishan-Bagaria Featured By Owner May 27, 2010
Why don't you change the Framework to 2.0 ? VS 2010 has the feature. If you do so, Vista users will not need to download .net Framework 3.5.
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner May 27, 2010  Professional General Artist
Mmmmm.....OK I'll think over it.
Reply
:iconkishan-bagaria:
Kishan-Bagaria Featured By Owner May 27, 2010
Vista already has .net Framework 3.0 installed. That's why.
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner May 27, 2010  Professional General Artist
Thanks for that information.
Reply
:iconkishan-bagaria:
Kishan-Bagaria Featured By Owner May 27, 2010
np
Reply
:iconratchet-lombris:
Ratchet-lombris Featured By Owner May 15, 2010  Hobbyist Photographer
Very nice!!
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner May 15, 2010  Professional General Artist
Thank you very much for appreciating my work.
Reply
:iconratchet-lombris:
Ratchet-lombris Featured By Owner May 15, 2010  Hobbyist Photographer
It's okay! It's very nice :3
Reply
:iconfediafedia:
fediaFedia Featured By Owner May 14, 2010  Professional Interface Designer
I dont work in visual basic '10, but it looks pretty much done to me
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner May 14, 2010  Professional General Artist
Thanks anyway.
Reply
:iconshikharsrivastava:
ShikharSrivastava Featured By Owner May 14, 2010  Professional General Artist
Please comment and give suggestions.
Reply
Add a Comment:
 
×
Download ZIP download, 750 KB



Details

Submitted on
May 14, 2010
File Size
750 KB
Link
Thumb
Embed

Stats

Views
6,060
Favourites
24 (who?)
Comments
30
Downloads
971

License

Creative Commons License
Some rights reserved. This work is licensed under a
Creative Commons Attribution-Noncommercial-No Derivative Works 3.0 License.
×